Tuesday, December 01, 2009

Novation Launchpad: Ripple Sequencer with Retriggers



Download the patch here.

How to set it up:
• Connect the LaunchPad to your computer
• Open up the Max/MSP patch in Max runtime or environment
• Open up Ableton Live
• Quite Automap
• Route the MIDI Launchpad input and output fields in the Max/MSP patch to and from the Launchpad port
• Route the External MIDI output field in the Max/MSP patch to a virtual MIDI patch (in Mac OS X, this means an IAC Bus - for Windows users, this could mean one of a number of virtual paths depending on your software I think)
• In Ableton Live create a new track with an instrument on it of your choosing
• Set the input to the same virtual path you chose earlier
• On the LaunchPad, hit the 'view / down arrow' button
• Set the speed in milliseconds in the Max/MSP patch
• Click on the toggle next to the speed control


How to use it:
• Press a button in the grid area
• A yellow ripple should appear
• On the LaunchPad, hold the 'view / down arrow' button
• Press a button in the grid area
• The button will turn red - this is a note
• On the LaunchPad, hold the 'page left / left arrow' button
• Press a button in the grid area
• The button will turn green - this is a retrigger point

11 comments:

amsonx said...

Thank for this piece of software Little-scale

I'ts really nice

meto said...

this is big fun, thank you so much!

I was a bit confused at the beginning, but then I realized that I have to disable the lauchpad as control surface in the ableton preferences...

Meng Qi said...

Thank you very much for sharing!

Regards,
/M.Q.
Http://mengqimusic.blogspot.com

guy smiley said...

brilliant . thanks !

malutki said...

wow, this is really sweet!
will this work in maxforlive aswell?

Dragoljub said...

Cool! This is exactly the type of thing I wanted to do with Launchpad and Max for Live! :)

Edit Machine said...

Thank you little-scale, this is an amazing piece of software. It is so much fun to play with and it really inspires creativity :)

jamie said...

Thanks for sharing this. Looks fantastic!

Izwiz said...

I love your work - yr CMOS circuits are especially superb. Sadly I'm being very feeble with making the Shapeseq work. Followed Set Up carefully but no yellow ripple. Live 8.1/OSX 10.6.4/MRT 5.1.4 - think my Ableton prefs may be wrong. Could you clarify please?

Izwiz said...

I love your work - yr CMOS circuits are especially superb. Sadly I'm being very feeble with making the Shapeseq work. Followed Set Up carefully but no yellow ripple. Live 8.1/OSX 10.6.4/MRT 5.1.4 - think my Ableton prefs may be wrong. Could you clarify please?

Izwiz said...

Hi again - you may want to delete my last post - have sorted out the Ableton settings & it's superb! Thanks again for your excellent work.